0

I have run many versions of QGIS 2 and 3 on two Mac computers. I have not been able to get 3.16.5 (LTR) or 3.18.1 to work on either of them. However, on a third computer which has never had QGIS installed on it, both 3.16.5 and 3.18.1 install and run fine.

I suspect that some leftovers from previous versions of QGIS are causing the problems. I have tried removing the profiles by trashing the folder ~/Library/Application Support/QGIS and emptying the trash. The problems persist.

Symptoms:

  1. Opening an existing project crashes
  2. Creating a new project in 3.16.5 and changing the project CRS gives an error message:

No transform is available between ESRI:102747 - NAD_1983_StatePlane_Virginia_South_FIPS_4502_Feet and Custom CRS: GEOGCRS["unknown",DATUM["unknown",ELLIPSOID["GRS 1….

proj_create_operations: cannot build geodeticCRS 4326: SQLite error on SELECT name, ellipsoid_auth_name, ellipsoid_code, prime_meridian_auth_name, prime_meridian_code, area_of_use_auth_name, area_of_use_code, publication_date, deprecated FROM geodetic_datum WHERE auth_name = ? AND code = ?: no such column: publication_date

It does not matter which CRS I choose, a similar error message appears.

The QGIS about panel shows the same information on both the working and non-working systems (except that the working system is Mojave. However, I had this problem before I upgraded to Big Sur, so Big Sur is not likely to be the problem.)

This about panel is from one of the non-working systems:

QGIS version
3.16.5-Hannover

QGIS code revision
58ba7c1ed6

Compiled against Qt
5.14.2
Running against Qt
5.14.2

Compiled against GDAL/OGR
3.2.1
Running against GDAL/OGR
3.2.1

Compiled against GEOS
3.9.1-CAPI-1.14.2
Running against GEOS
3.9.1-CAPI-1.14.2

Compiled against SQLite
3.31.1
Running against SQLite
3.31.1

PostgreSQL Client Version
12.3

SpatiaLite Version
4.3.0a

QWT Version
6.1.4

QScintilla2 Version
2.11.4

Compiled against PROJ
6.3.2
Running against PROJ
Rel. 6.3.2, May 1st, 2020

OS Version
macOS 10.16


Active python plugins
processing; 
db_manager; 
MetaSearch

What may need to be removed?

A clean install of MacOS is out of the question because there are too many current projects in too many different applications.

6
  • Just some info to help you out, but ive got QGIS 3.12, 3.14 and 3.16 all installed on a single machine (albiet, a windows machine). They all run fine and independent of each other and I don't get any issues. I do know that there is a folder in indows called 'C:\Users\<username>\AppData\Roaming\QGIS\QGIS3\profiles\default' and this contains templates/python/themes etc, I would be looking for macos equivilants of those.
    – nr_aus
    Commented Apr 14, 2021 at 8:01
  • How do you install QGIS ? Commented Apr 14, 2021 at 8:15
  • Delete / Application Support/ GDAL and reinstall maybe? It's a CRS issue, so I'd look there.
    – wingnut
    Commented Apr 14, 2021 at 8:27
  • I'm running 3.18 on Mojave. GDAL 2.2 and 2.3 are in Library/ Application Support/ GDAL
    – wingnut
    Commented Apr 14, 2021 at 8:28
  • @wingnut I did find /Library/Application Support/GDAL with several versions, removed it, removed QGIS-LTR.app, rebooted and reinstalled 3.16.5 from the .dmg file. Same symptoms persist.
    – kbjshop
    Commented Apr 14, 2021 at 20:28

2 Answers 2

0

I have run the installers from kyngchaos for 3.16.5 which installs python3.9 and GDAL separately.

I also deleted the profiles at ~/Library/Application Support/QGIS and deleted a slew of QGIS preference files at ~/Library/Preferences (e.g., org.qgis.qgis3.plist)

Now the symptoms have changed:

  1. QGIS 3.16.5 crashes immediately

  2. on 2nd try, QGIS starts with message that Processing plugin caused a crash and has been disabled. Enabling Processing immediately crashes QGIS.

  3. If I leave Processing disabled, I am able to open my project files (progress!)

  4. Also There is now no problem with changing CRS on a new empty file. (progress!)

Of course, I can't work with Processing disabled.

I am going to try installing 3.18.1 from kyngchaos to see if anything improves and I will report back.

Note: The readme for the installer mentions needing to change some values in preferences for Processing.. Of course, those preferences cannot be accessed if Processing plugin is disabled. Catch 22. However, since I deleted the preference files in ~/Library/Preferences, I assume this would have taken care of this issue.

Update after installing QGIS 3.18.1 from kyngchaos, deleting profiles and deleting preferences:

Symptoms remain as reported above.
1)QGIS upon startup shows the splash page with version number, then crashes. 2)On second startup attempt, Processing is disabled and QGIS runs.

Presumably there is a conflict of versions of something.

5
  • Are you on a new Apple silicon Mac? Also, note that Your Processing preferences are under Settings-Options, not under Processing. If you can see this menu, try deactivating the providers one by one to see which one is causing the problem. Finally, ~/Library/Application\ Support/QGIS/QGIS3/profiles/default probably has your defaults. Confirm in Settings-User Profiles. Delete it on a fresh install and see what happens when you start QGIS (you will lose all installed plugins).
    – wingnut
    Commented Apr 15, 2021 at 1:52
  • What kind of Mac and OS? Is it M1?
    – wingnut
    Commented Apr 16, 2021 at 10:22
  • There are two computers that have the above symptoms: #1) an iMac Pro (2017) running Big Sur, and #2) a Macbook Pro (2019) running Catalina. Both machines share a similar history of installed software, including various QGIS versions. On a third machine, 3.16 works fine. It is a 2013 Mac Pro (cylinder) running Mojave. It has never had QGIS installed on it before. I installed 3.16 as a test when I started having trouble on the other two. None of the machines involced are M1.
    – kbjshop
    Commented Apr 19, 2021 at 13:20
  • I have had one more thought that I will be checking -- I installed NExtGIS a while ago on both machines in order to try it out. When I have a moment, I will see about thoroughly uninstalling that.. on the odd chance that it has a library or a framework tucked away somewhere that is bothering QGIS 3.16... that seems very unlikely, but I thought I'd mention it. (NextGIS has not been on the 2013 mac pro which runs 3.16)
    – kbjshop
    Commented Apr 19, 2021 at 13:24
  • Likely to be a modification of your default path. I'd make a note of your path from a Terminal, install NextGIS, look at the path again and see what changes. You can probably alter the path manually in QGIS or run it from a command line, where you have explicit control of the path. Then you should be able to run both applications. It may even be a change that can be made permanent, so you can double click as usual.
    – wingnut
    Commented Apr 20, 2021 at 3:48
0

SOLVED: NextGIS seems to have been the conflicting software. About a year ago I tested NextGIS. The NextGIS installer version was 3.12.

NextGIS was on both systems that could not run QGIS 3.16.5 and it was not on the machine that could.

I ran the NextGIS uninstaller and it cleared up the problem on both of my systems that were unable to run QGIS 3.16.

I have tested QGIS-LTR.app (v 3.16.5) from the All-In-One installer on both machines and it works now that NextGIS has been removed.

Here are the steps I took:

  1. Open QGIS-LTR.app (v 3.16.5) to test if it runs this morning (All in one version). It does not.
  2. Run NextGIS uninstaller.
  3. Open QGIS-LTR.app (v 3.16.5) again. It still crashes immediately.
  4. Remove ~/Library/Application Support/QGIS
  5. Remove ~/Library/Preferences/org.qgis.qgis314.plist
  6. Test QGIS-LTR.app (v 3.16.5). It starts but has disabled Processing.
  7. reboot
  8. open qgis-macos-ltr-5.dmg (which is the 3.16.5 all in one installer) and copy QGIS-LTR.app to Applications
  9. Open QGIS.LTR.app (v 3.16.5). It opens with Processing enabled (progress!!!). It also opens my projects saved from Version 3.14 (SUCCESS!!!)
  1. Also checked the other symptom -- changing CRS on an empty project, and that works now too.

I have not yet tested the kyngchaos-installer versions. I will probably stick with the all-in-one for now.

It remains a mystery to me what about NextGIS was conflicting with 3.16 and 3.18 but NOT with 3.14.

Thank you for your help along the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.