2

I am trying to install the QGIS Desktop application on Windows 10.

Upon a successful install, only the OSGeo4W Shell and the Grass GIS 7.8.5 are there on the apps list (within the QGIS folder), the actual QGIS Desktop app is not there.

I get the .exe file from the regular qggis dot come downloads website ("QGIS-OSGeo4W-3.16.5-1-Setup-x86_64").

I've tried with both the 64-bit standalone installers for 3.16 Hanover and (latest) 3.18 Zurich version. This process has worked just fine in the past.

My computer's virus protection program Sophos Endpoint Agent keeps detecting and clearing a file named nircmd.exe from the QGIS/3.1x/bin folder, wondering if that has anything to do with it (says "Threats cleaned up. NirCmd detected at file path..."). I don't know what I'm doing wrong now or what is missing. Please help.

1

Run OSGeo4W - this will open a terminal.

Type qgis in that terminal end hit Enter.

If you don't see 'qgis', try 'qgis-grass7' etc.

8
  • I typed qgis in the OSGeo4W Shell terminal and it returns: "'qgis' is not recognized as an internal or external command, operable program or batch file." – vlade113 Apr 16 at 10:01
  • type o-help >temp.txt in the same window. I guess 'qgis' is not in the list of executables? – wingnut Apr 16 at 10:14
  • Actually, installing OSGeo4W should install qgis for you. Are you installing some other way? – wingnut Apr 16 at 10:15
  • I am only doing a regular install, ran the executable files named QGIS-OSGeo4W-3.16.5-1-Setup-x86_64.exe and QGIS-OSGeo4W-3.18.1-1-Setup-x86_64.exe downloaded from qgis.org/en/site/forusers/download.html – vlade113 Apr 16 at 10:20
  • Okay, the o-help >temp.txt produced results. I found that the command qgis-grass7 works, it opens QGIS Desktop. And now the QGIS3 App appeared under the QGIS folders – vlade113 Apr 16 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.