2

I want to join a vectorlayer with a grid using the algorithm "join attributes by location (summary)". It took hours to execute, but it worked. Then I found This thread which told me I have to create a spatial index for the layer first. So I did that for the vector layer, but after executing the algorithm "join attributes by location (summary)" again, all values in the desired field were zero? It took only 2 seconds to execute, but there were no values? What could be the reason for that?

Update: I thought I found what was the issue: To speed up the process, I deleted all fields except my value field. There must be an ID-Field which acts as the spatial index though, so my fault was to delete this one as well. So I did it again, leaving this field there, and it worked! But it only worked once, all tries after that executed right away, but once again, I got no values, just zeros...

1 Answer 1

1

Well, after creating a new vector layer and a new grid, it worked again - I guess once a spatial index is created, it will only work one time?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.