3

Normally, in ArcMap Print layout, enabling the grids and specifying the intervals would show the curved grids as in the following map:

Stock map of Mongolia

But in QGIS, enabling the grids (1) does not have an option of showing the coordinates in DMS, (2) reveals wrong coordinates, (3) is not curved like in the previous map:

enter image description here

I assumed it was an error with the projections and made sure that the map was assigned the same CRS (WGS84 - UTM Zone 48N) as the project, but the last photo was still the result.

I saw a "solution" that changing the projection to EPSG:4326 WGS84 would supposedly allow for DMS units to be shown, but changing the projection to WGS84 returned an ugly output:

enter image description here

where the coordinates were still incorrect.

How would one go about (1) displaying the correct grid labels as DMS, (2) show the gridlines in a curved fashion on a map projected to UTM on QGIS 3.18.1?

Grid settings:

Grid settings

Draw Coordinates settings

8
  • Please provide your grid settings as screenshot.
    – Erik
    Apr 19 at 13:25
  • Okay, I have added them in the post.
    – sokhymi
    Apr 19 at 13:29
  • If you want DMS coordinates you need to set the CRS for the grid accordingly.
    – Erik
    Apr 19 at 13:32
  • Could you elaborate? I'm fairly new to QGIS, and I haven't encountered settings for grid CRS other than that in the above photo. It's set to the CRS I want it to be projected to.
    – sokhymi
    Apr 19 at 14:28
  • Set it to EPSG4326. That's the global CRS for DMS-values.
    – Erik
    Apr 19 at 14:29
3

The project CRS should correspond to your main data, i.e. in UTM (32648)

If you want to show a grid in degrees, you must set the grid CRS to 4326, and only then you can show the coordinates as decimal degrees or DMS.

enter image description here

Note: if your grid is in UTM and the coordinates are to be shown as degrees, the output is complete garbage.

1
  • Oh, thank you! I was wrongly fiddling with the project CRS inside QGIS > File > Properties, but learned that I was supposed to also specify the UTM projection in the Main Properties panel in the settings on the map element in the Print layout.
    – sokhymi
    Apr 20 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.