1

I am totally new to either PostGIS or PostgreSQL. I am trying to install PostGIS on my computer, which is running with MacOS Big Sur version 11.2.3

I have installed PostgreSQL 13 with the EDB. Then I tried to install PostGIS 3.0 with the application Stack Builder, but I get an error message. I understand that it is a permission problem that often happens with Big Sur. I click on cancel the installation, and then I get this message :

"Please excute sudo /tmp/rZxm7Y/postgis-pg13-3.0.2-1-osx.app/Contents/MacOS/osx-x86-6"

I open the Terminal and run it but again I get an error message

"Command not found"

I have deleted "postgis-3.1.1.tar.gz" after a first attempt to clear everything, but now I don't know where it should be (Applications ? Library ? User ?).

I have also installed PostgreSQL and PostGIS with homebrew at some point, and it worked, but I've uninstalled it since, I don't feel confident enough to work without a GUI.

I have installed Postgres with success, but I am afraid it will conflict with my previously installed version of PostgreSQL. I've tried to uninstall it, but I can't find the uninstaller, even when I run find . -name 'Postgre*' -type d in the Terminal.

1
  • My experiences using Postgres.app have been positive. No separate PostGIS installation is necessary: you just use create extension postgis command at the db level to enable it. – Alexander Apr 19 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.