3

I'm using QGIS3.16.13 and when I add the scale-bar from "view > Decorations > Scalebar" to my map I noticed that it shows the wrong distance. I'm not talking about the print-composer, just the usual QGIS-interface. The scalebar is less than half of what I measure:

enter image description here

I know for a fact that this measurement must be correct (and the scale-bar must be off) as I know my raster's pixel-size is 0.5 m. So when I zoom in, on a single pixel an re-measure, the miss-alignment maintains roughly the same ratio: the scale-bar is circa half of what I measure: enter image description here

I found this question on a similar issue (but almost 10 years old). However, in contrast to the issue there, I use the same coordinate system & projection for my project, my raster-files and my shapefiles are all in (EPSG:32739 - WGS 84 / UTM zone 39S - Projected).

My measurement tool's settings are below. However, I think the issue is not a wrong measurment, but a wrong scale-bar, as the measurement for e.g. a pixle length is correct, regardless of zoom level: enter image description here

2
  • Please provide the settings of your measurement tool. – Erik Apr 21 at 8:49
  • Hi @Erik I did edited the question and added the settings for the measurement tool. – Vincé Apr 21 at 8:52
1

Somehow this issue was resolved, when I:

1. changed the project's coordinate system to a different reference system (select & apply) and then

2. changed it back (select & apply).

So the problem is resolved, what I don't understand is: why? I made sure, before considdering to post here that the project and the CRS of all layers/rasters is identical as I saw the question, which is also linked to in my post above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.