1

I've created a workbench where I simply need to add four columns into multiple features. I've tried a few different ways. The data has metadata in it so I just want to truncate the table or drop and create so it retains the metadata.

  • I used a dynamic writer, the error is random.
  • I tried a more manual way by just exporting "Create if needed" into an empty GDB and importing Metadata afterwards. Still no luck. Weird errors.
  • I tried an even more manual way by pushing one feature at a time through and having a non-dynamic output. This was random, sometimes it would work, but sometimes it wouldn't. I finally got this to work and pushed through 20 features before it decided to stop working and error "Cannot write a non-point feature to a point feature class" but the output is set to polygon! I've made several new writers and readers and workbenches, and used different features and new GDB's and I can not get this to work.

Please help!

enter image description here enter image description here enter image description here

3
  • Do you need to update just attributes in an existing Geodatabase? Is ArcGIS Pro or ArcMap installed on the same PC as FME?
    – Mapperz
    Apr 22 '21 at 20:42
  • @Mapperz Yes, just to update the attributes, I'm simply adding 4 columns to all features. Pro is on the same computer, yes.
    – Kim
    Apr 23 '21 at 7:04
  • 1
    I would use the featurewriter in update mode see an example here from shapefile to geodatabase gis.stackexchange.com/a/394675/276
    – Mapperz
    Apr 23 '21 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.