0

I export shapefiles with a defined coordinate system to a file geodatabase assigning the export coordinate system same as input file, but when I try to import them back into the project from the file geodatabase, they do not have an assigned coordinate system. Not sure where I'm going wrong.

enter image description here

enter image description here

2
  • 1
    It seems that you did not define the coordinate system on the shapefile (which generates a .prj file), but just set an environment which isn't used by FeatureClassToFeatureClass, so the information hasn't been lost, just not ever set. Have you tried using DefineProjection or creating a target feature dataset within the FGDB?
    – Vince
    Apr 26 '21 at 12:43
  • That's the thing, there are prj files and there is a defined geographic coordinate system, but just no projected coordinate system. But still when exporting to FGDB it ends up with an undefined coordinate system
    – hughbk
    Apr 27 '21 at 2:36
0

It turns out, when you create a a feature dataset within a file geodatabase, you have to define the coordinate system of the feature dataset to which you will import data at the time of the creation of the feature dataset (you cannot assign later), regardless of whether or not the data that you will import has a defined coordinate system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.