I have a brandnew installation of SuSe Linux leap 15.2, and installed the latest version of QGis (3.18). Installation with Yast runs fine, no errors.

However, QGIS does not launch from the start menu. Launching from the console gives an error message indicating a problem with the qgis library: qgis: symbol lookup error: /usr/lib64/libqgis_core.so.3.18.2: undefined symbol: GEOSCoordSeq_setXY_r

I tried also replacing the installation with the QGIS ltr version (3.16) but that gives the same type of error

Any tips how to resolve it?

1 Answer 1


The problem is solved. GEOSCoordSeq_getXY is in the GEOS library.Steps taken:

Check with the Yast software manager which GEOS version is installed. This version should be 3.9. If another version than 3.9 is installed, replace it with 3.9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.