1

I am exporting selected features from a feature class and creating a new feature class within the project geodatabase. The export runs and the feature class is created but the features are not visible. The attribute table is correct, it shows there are features in the file but they do not display. I have tried this with multiple feature classes and I am getting a similar result. I even tried exporting to shapefile and got the same result. I am using ArcGIS Pro 2.7.2.

Has anyone else run into this and if so is there a solution?

I've tried recalculating the spatial index, deleting and recreating spatial index, projecting the file. Nothing has worked.

1
  • It seems to have something to do with the Spatial Index.
    – robmclau83
    Commented Apr 28, 2021 at 19:30

2 Answers 2

0

Try to change your default Geodatabase. Check your spatial reference. Check if there is any selected record.

0

I just ran into this issue. I noticed that when I was running the geoprocessing tool there was a notice that there were pending edits that had yet to be saved. Once I saved the edits and re-ran the tool it worked just fine. I don't think the edits were on that particular feature class which is why I didn't give it a second thought initially. But perhaps that's something you might find resolves the issue in the future?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.