0

I have a raster that I can't open in QGIS. When I load the raster, I get the following message:

CRITICAL Capa no válida: GDAL provider cannot open GDAL dataset C:\Users\Name lastname\Destktop...

Raster layer El proveedor no es válido (proveedor:gdal, URL: C:\Users\Name lastname\Desktop...

I must say that I can open the raster in other laptops but not mine... so that means, the file is ok. I’m running windows version...and I’ve had the issue with the 3.18.2 and 3.16.4 as well.

enter image description here

5
  • Can you be more specific. Can you open the same file in QGIS on different computers? Can you open the file in an image browser on the computer that is giving you trouble?
    – GBG
    Apr 28 at 23:06
  • What is the image extension? Are you sure you have all the parts? Some formats split the data, for example ERDAS IMG with file size greater than 4GiB separate the data into a .img and .ige, BIL/BSQ files have important information in the .hdr file but the data is in another file. Can you try moving it to a different folder that is not desktop or in the C:\Users tree? Apr 29 at 1:07
  • Can you give me an example of such a directory that it’s not an users tree? I tried from an usb but it didn’t work. My user name has a space but I don’t know how to change that, I guess that’s not easy to do (I’m running in windows).
    – Jaydi_21
    Apr 29 at 2:47
  • I have all the parts, it’s a .tif file. I have not tried in a browser but I do know that others can open this file in another QGis. I tried uninstalling QGis to install the LTR version (I had the 3.16.4). I made a mistake and I got the 3.18.2 installed, so I tried one more time to open it and I got the same error. But I’m curious because I thought that after uninstalling the 3.16.2, I’d have to install again the complements and they were there...so I’m not sure how to remove that and get a completely new installation.
    – Jaydi_21
    Apr 29 at 2:52
  • Windows / Mac / Linux? OSGeo4W?
    – wingnut
    Apr 29 at 3:59
1

That seems to be a low level error from libtiff library. By the error message the libtiff function cannot read data from a certain part of the TIFF file. Directory here means the internal directory that TIFF file has and offset means the number of bytes from the beginning of the file.

Either your copy of the TIFF file is corrupted or you have a different version of libtiff than those who can open that image image have. By this information it is not possible to say if there is a bug in your libtiff version or if the TIFF file really is invalid but another libtiff version does not notice it.

Try to get another copy of the file DEMnicaragua.tif and have another try to test if your file is physically corrupted. If that fails also you may ask someone who can open the image to write the file into a new GeoTIFF with QGIS or GDAL. Perhaps the TIFF directories in the re-written version are organized differently and your libtiff version would be happy.

2
  • Don’t you think that getting the LTR version would help? You think there is an issue with that copy of the file?
    – Jaydi_21
    Apr 29 at 12:25
  • If the file opens for somebody else but not for you I can see only two alternatives: either the image is not the same or there is some difference in the software.
    – user30184
    Apr 29 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.