0

I’m using the extents of one vector to clip another, using GDAL Vector processing “Clip vector by extent” function. Both vectors are encoded as UTF-8. So why the resulting vector is encoded as ISO-8859-1, although my Linux system also uses UTF-8 as default?

I’ve seen similar questions, but my version of QGIS (3.18.1-Zürich) does not have a Ignore shapefile encoding declaration under Settings, Options, Data sources, Data source handling, nor do I find an “Encoding” option under project properties.

8
  • First, try doing it with QGIS's own Vector - Geoprocessing Tools - Clip menu option.
    – wingnut
    Apr 29, 2021 at 3:52
  • @wingnut That's my first idea, but it doesn't have an “extent” feature, instead it clips by the polygon, which is much slower.
    – Rodrigo
    Apr 29, 2021 at 3:57
  • Read this question. It may help. gis.stackexchange.com/questions/15912/…
    – wingnut
    Apr 29, 2021 at 4:06
  • Why not to save into geopackage that is always UTF-8?
    – user30184
    Apr 29, 2021 at 6:54
  • @user30184 Yeah, I may try different formats. Just thought that UTF-8 was already universal, at least in Linux.
    – Rodrigo
    Apr 29, 2021 at 7:09

1 Answer 1

0

According to the answer given by unicoletti, linked by wingnut in the comments, I've discovered that I can use the following option:

-lco ENCODING=UTF-8

in the Additional creation options field. However, I believe this should be the default, since we're in 2021, and the majority of the world does not speak English.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.