1

I have cloned my ArcGIS Pro env into my Anaconda 3 env. My goal was to have access to both the arcpy mod and GeoPandas mod. I tested it in a notebook to make sure arcpy is working and it is. But GeoPandas is not in >conda list. I tried to install it both from the Anaconda Navigator package manager and using >conda install geopandas. Both returned the same error: InvalidSpecError: Invalid spec: =2.7. I've tried to use pip as well. In addition, I tried other solutions, including this solution and this solution where I completely removed and tried to reinstall my gdal package and reinstall geopandas first. It failed and ruined the gdal package in the process. I have tried to clone my arcpgispro-py3 env to see if I can add it that way, but the clone attempt keeps failing. Is there any way to do this or is there some ESRI configuration that makes this impossible?

3

Geopandas is included with Python for ArcGIS Pro. See the image below. Maybe you have cloned your environment but your Python environment defaulted back to the walled garden version for some reason?

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.