0

This question came from another topic: QGIS - creating VRT does nothing.

MacOS High Sierra (10.13), QGIS 3.10 Coruña, GRASS 7.8, GDAL/OGR 2.4.1, Python 2.7 The installation of GRASS was tricky (qgis config of several path to GRASS location)

I would like to create a VRT ("menu:raster:miscellaneous:Build virtual raster") or with toolbox:GDAL. When I open the window to select my files and hit "ok", both VRT window and select box close and it does nothing. When I try to merge several .asc file I get the same result. When I try to create contour, it runs but log says that the result layer was not correctly generated.

Is the computer (8go Ram) just out of memory? (each asc file has 1 million points, it made a lot, but with just 4 tiles it does the same "nothing")

I guess a Python problem with a bad configuration of QGIS/Python. Got this "Python warning":

warning:/Applications/QGIS3.10.app/Contents/MacOS/../Resources/python/qgis/utils.py:737: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses mod = _builtin_import(name, globals, locals, fromlist, level)

I can't figure out which "utils.py" is failing and where it is located, inside qgis or python. Do i have just to upgrade Python or Qgis? Or the plug-in which look to be the latest?

1
  • I think you need to upgrade. – wingnut May 6 at 17:21
0

wingnut, as you suggest made the upgrade to recent build. The VRT plugin doesn't crash anymore (good new) but still output nothing and log error :

GDAL command output : dyld: Symbol not found: __cg_jpeg_resync_to_restart Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO Expected in: /Applications/QGIS-3.18.app/Contents/MacOS/lib/libjpeg.9.dylib in /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO /Applications/QGIS-3.18.app/Contents/MacOS/bin/run_gdal_binary.bash: line 13: 50284 Abort trap: 6 "$THISDIR/_$ALGNAME" "$@" Process output error code 134 Execution completed in 0.23 seconds

The dylib "/Applications/QGIS-3.18.app/Contents/MacOS/lib/libjpeg.9.dylib" exist checking inside the package. The 3 folders pointed by "run_gdal_binary.bash" exist. Seem that something wrong beetwen GDAL and libjpeg.9.dylib ?

By the way, at startup Qgis warn : "GRASS init error : Error starting GRASS, ……… : Module built against version 2021-02-10T17:13:06+00:00 but trying to use version 2021-02-10T17:08:53+00:00. You need to rebuild GRASS GIS or untangle multiple installations." The previous version of Qgis was trashed but somethings remain.

By exemple, the folder "svg" in the panel "preference:system:option:svg path" is missing : "/Users/MarJo/Library/Application Support/QGIS/QGIS3/profiles"/default/svg/ is missing.

9
  • I get that too. If you want to avoid this, you need to modify the DYLD_LIBRARY_PATH environment variable to include all the .dylib files (I believe). With GDAL and SAGA, I just run from the command line. saga_cmd is the executable. Make sure it's in your path and get the options from the QGIS toolkit panel. Same with GDAL. Particularly with GDAL, it's easier to run things from the command line anyway, and it forces you to save files rather than create memory layers. – wingnut May 10 at 14:02
  • Thanks wingut, i 'll look that tonight. – MarJoM May 10 at 15:11
  • If you have any success, please answer your own question and explain how you solved it. I think it willl help a few people. – wingnut May 10 at 17:25
  • Back to that issue… Can't figure how/where to configure DYLD_LIBRARY_PATH… I guess the path to "/Applications/QGIS3.app/Contents/MacOS/lib ? "Also i notice that the Qgis folder doesn't exist in my /Users/MarJoM/Library/Application Support/QGIS/QGIS3/ . It is pointed in the system-option panel by the var GDAL_PAM_PROXY_DIR, to the svg symbols, or as output folder in the General option, or with the scripting and models folder. Quite confusing. – MarJoM May 17 at 10:39
  • Broadly speakig, locate the application's dynamic libraries and append their location to the path. I'm without my Mac for the next few months, so I cannot experiment. – wingnut May 17 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.