9

I am using QGIS 3.18 on Windows. Whenever I edit a legend text in Layout view my computer gets very worked up. My CPU temp rises dramatically and the process of typing is really slow. Every single letter that I type takes perhaps 5-25 seconds to type. Instead I am using copy+paste, then I only have to wait once. But a process that could take a minute (to edit 5 rows of legend text) takes much longer time.

Has anyone else encountered this problem?

Edit: Actually the process of editing anything about the legend, for example removing layers that are not to be included in the legend, takes a very long time.

3
  • 2
    I encountered the same problem. But I didn't think what the problem was. I use copy/paste, too. May 12, 2021 at 12:22
  • yes I experience this all the time, from 3.16 all the way to 3.22
    – Theo F
    Oct 26, 2022 at 10:20
  • Perhaps related, since I installed the latest QGIS 3.30.1 ''s-Hertogenbosch' version, if I copy some text and paste it in the legend (for example, renaming some of its items), QGIS automatically shuts down. It definitely seems there's a lot to improve with the legend edit.
    – Trikelians
    Apr 7, 2023 at 5:35

3 Answers 3

2

I experienced the same issue. I did find a workaround to the problem.

I had several projects where I was experiencing the issue, and one where I did not have the issue. Since the projects were almost identical in data, I could look at what settings in my legend were different, and was probably causing the problems.

The difference I could find was that the legend in the project that was running smoothly was not connected to a map item, while the legends in the other projects did have a connection to a map item (see pictures below of the item properties of both legends). When I removed the connection from the legend to the map the editing of the legend was running smoothly again.

enter image description here

enter image description here

I wasn't able to just remove the map connection from the legend. I had to delete both the legend and map, and re-add them for it to work. Make sure to add the legend first and then the map, so the legend will not be connected to the map.

1
  • Unfortunately, based on your last sentence, the legend will auto-link the map when you add it. I'm using 3.22. There's no way to have no 'Map' item selected.
    – Theo F
    Oct 26, 2022 at 10:25
1

Far from perfect, but turning the visibility of the legend off during editing works (3.22).

0

Similar to the previous, the following worked for me and didn't require deleting anything:

  1. create a 'dummy' map object off screen
  2. on 'dummy' map object, zoom in as much as possible while keeping at least one feature from the layers you need in view
  3. link the legend to the 'dummy' map

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.