4

I've got problem with transparency when exporting my layout to PDF file. I have layer with transparency defined in Symbology -> Layer Rendering -> Opacity.

enter image description here

In map view and in layout i can see transparency in my layout:

layer is transparent in map and layout view

However, adter exporting to PDF transparency is gone and edge of polygon looks weird:

no transparency after exporting to PDF

My PDF export settings are:

PDF export settings

What solve this issue, but I can't use it because of other reasons:

  • Checking "Print as raster" in Layout Settings

enter image description here

  • Define transparency right in the color of symbol, not in "Opacity" of layer.
  • Exporting as image
  • using older varsion of QGIS (works in 3.2)

As I've mentioned, i can't use any of this solution.

What I've tried:

  • Enabling/Disabling "simplify geometry"
  • Enabling/Disabling "Always export as vector"
  • Enabling/Disabling "Export RDF metadata"
  • messing up with other layer-, layout- and export settings. All things that works I've mentioned above.

Someone has this exact problem earlier, but no satisfying answer was provided

Do you have any ideas how to fix that issue? Am I doing something wrong?

3
  • This sounds like a regression, I don't know if it's a known regression but in the case that it isn't you can write an issue on the QGIS github page – JonasV May 17 at 10:11
  • It's actually mentioned here – jgruszka93 May 17 at 10:15
  • I had the same problem after updating to 3.16. Choose "Geospatial-PDF" in the export-options. The export lasts some time, but the result corresponds to the layout. – Andrea Jul 7 at 9:40
2

I have the same problem (QGIS v. 3.18.3; Qt v. 5.11.2). My guess is, it is a bug: The export, for some reason, does not take into account the opacity settings done in the 'Layer rendering' sub-menu. Instead, you need to adjust the opacity directly inside the symbol-style settings, for the export to work properly. So basically, transparency needs to be manually adjusted for each respective symbol of your vector layer.

This is highly impracticle for larger legends, but the only solution I could come up with so far.

0

A way around is to set the map in the print layout to "multiply". Then as you set the pdf print, a message will pop out telling you that the pdf will be printed as raster. The transparency will show.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.