6

In QGIS For some reason, the identify tool doesn't work on the layer I have selected in the TOC. Instead, it just selects whichever the largest overlapping layer is. For example, I want to identify a point that's within a larger polygon, it will always select the polygon even if the point layer is highlighted. So in order to use identify to check the point, I have to deselect every layer that's overlapping the point layer. It's a bit annoying since I work with several land classification layers that overlap one another.

This only started a few months ago, any way to.

2 Answers 2

12

At the bottom of your identify-tool-window you may choose, which layer(s) the tool accesses.

Currently you probably have the second option (top to down, stop at first), which is why you have to turn off all layers "above" your pointlayer. If you choose current layer, the identify tool will access only the layer you highlighted in the layer window.

enter image description here

5
  • 4
    Didn't know that, learned something new!
    – Babel
    May 19, 2021 at 12:42
  • 3
    You may even rightclick the map canvas when the ID-tool is activated and then choose, which of the visible layers you want to query - or even all of them @Babel. Though I seldom use this feature.
    – Erik
    May 19, 2021 at 12:45
  • 1
    The hidden gems of QGIS - there might be much more out there to be discovered one day.
    – Babel
    May 19, 2021 at 12:46
  • @Erik I use the right click daily when I want to get a raster value that is my active layer and then want to directly edit a point without fiddling around in the layers panel. It's useful for the few tasks where this can't be automated in any way.
    – Gabriel
    May 19, 2021 at 12:58
  • I didnt know this, thanks so much! somewhere along the way I must have switched it to that option. You just saved me lots of time and frustration... cheers! May 20, 2021 at 13:47
5

You didn't add a screenshot, but I suspect that you did not select the layer you want to use the identify tool on. How did you select it? Just checked the checkbox next to it? That doesn't work. Go to the layer panel and click with the mouse on the layer, so that it is highlighted. If you press F6 (at least in Win), you see the attribute table opens: if it's the attribute table of another layer, you "selected" the wrong one.

Screenshot: the layer land is selected (but not visible), the following 5 layers are visible (checkbox checked), but not selected:

enter image description here

1
  • Yes the layer was selected as I mentioned in the question. I thought that was clear but maybe I should have included a screenshot so more people would understand. May 20, 2021 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.