0

Once I load a shapefile, double check my CSR, then Raster>Georeferencer> , nothing happens. I know this is the point that I should load a file to georeference. Again, nothing happens. I have removed all QGIS installs, reloaded both 3.4.14 and 3.8.3 with no luck. An aquaintance suggested that there may be issue with the program running against GDAL/OGR 2.4.3. What ever that means.

What should I do to get the Georeferencer to work?

QGIS version 3.4.14-Madeira QGIS code revision QGIS code revision Compiled against Qt 5.11.2 Running against Qt 5.11.2 Compiled against GDAL/OGR 2.4.3 Running against GDAL/OGR 2.4.3 Compiled against GEOS 3.8.0-CAPI-1.13.1 Running against GEOS 3.8.0-CAPI-1.13.1 PostgreSQL Client Version 11.5 SpatiaLite Version 4.3.0 QWT Version 6.1.3 QScintilla2 Version 2.10.8 Compiled against PROJ 5.2.0 Running against PROJ Rel. 5.2.0, September 15th, 2018 Active python plugins AreaAlongVector; AttributeAssignment; FeatureGridCreator; Hotlink; ImportPhotos; mmqgis; qgsAzimuth; quick_map_services; shapetools; SpreadsheetLayers; db_manager; MetaSearch; processing

1
  • Is it possible to upgrade to 3.16 LTR or 3.18? qgis.org
    – Mapperz
    May 20, 2021 at 2:33

1 Answer 1

2

It's always a challenge to help people with site-specific installation issues, and it's perhaps not best suited to this forum (gis.stackexchange.com).

But let me try to give a generalizable answer that will hopefully benefit you now and others later.

QGIS exists as part of an ecosystem of open-source geospatial tools. QGIS displays, edits, and does processing on layers of geospatial information. It uses GDAL/OGR under the hood as a "data provider" (one of several, to be accurate) to access the underlying data.

You do seem to be using both a quite old version of QGIS, and of GDAL/OGR. The latest version of QGIS is (at time of writing) 3.18.3 (3.16.7 for the LTR) and of GDAL is 3.3.0. I'm not sure what issues since fixed might exist in your old configuration, and/or what other installation issues might be present given your nonstandard installation, but I'd suggest as a start installing from scratch with the latest version.

2
  • Thank you, Houska, for you answer and advice. I did fail to mention that I had tried a newer version (3.8) and it did the same thing. This morning I loaded 3.18.3 onto my machine, and had the same issue. I understand tha site specifc issues can be a challenge, but I have no other place to turn other than stackexchange. May 24, 2021 at 15:11
  • Carl, do you now also have gdal 3.3? Just a shot in the dark, but who knows what might happen if gdal 2.4 is still on the machine. The same screen you pasted from before should indicate. Sorry, no easy answers!
    – Houska
    May 24, 2021 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.