1

What I am trying is to add a new field to an existing feature class in file GDB, overwrite this feature class and continue with processing. So far I tried to read that feature class connect to AttributeManager to add new field and FeatureWriter to overwrite it, but for some reason it doesnt update my current feature class. How this can be done in FME 2021?

enter image description here

2

Without seeing the details of your FeatureWriter, I would suggest the following:

In the FeatureWriter, ensure your Table Handling is set to "Drop and Create". This should delete the feature class and recreate it. enter image description here

However, it's important to understand the locking that can be in place with a file geodatabase. It's possible that if someone else (including you) has this feature class open, then there may be a lock preventing you from deleting it.

The other thing that is important is how your User Attributes are configured for the writer. If set to Manual, and you haven't specified the new field, then it won't create the field.

enter image description here

If you have it set to Dynamic or Automatic, then you will get the new field, but you may also end up with other fields that you don't want, depending on what is exposed in your reader.

3
  • the thing is that I dont want to delete and recreate the existing feature class! I just want to add some more columns on it and continue with the processing without making a copy of my current feature class.... Sorry if my question was not very clear
    – gisgis
    May 27 at 20:08
  • The thing to remember is that - if you are adding a new field to an existing FC, which has existing data, then ALL records in the FC are going to need to be updated to reflect a value for that new FC. Given that all records will be updated is the reason why some people prefer to just drop and recreate the FC from scratch.
    – nr_aus
    May 28 at 2:00
  • @Fezter this is exactly what I wanted. Thanks a lot. I think I just misunderstood the meaning of "drop and create" but this solved my problem. Thank you again. Furthermore I had wrong output port as Mark Ireland realized.
    – gisgis
    May 30 at 9:57
2

From a debugging perspective, try the following:

  • As above with Fezters answer - Ensure that you set your writer to 'Drop and Create' it will drop the current FeatureClass (ie: remove it) and then recreate it from scratch, with the specified attributes and data.

  • Use AttributeCreator transformer when creating new attributes. This may solve your problem.

  • Also, I would debug your bench by replacing the FeatureWriter, with just a normal writer. In theory it should be the same but it will at least confirm that the transformer type is the issue.

  • Finally, I would just try a different writer format. This will inform you whether its having issues writing to the format (being the same as the reader).

Go from there and post back whats happening if the above doesn't solve it.

2

If you're reading and writing to the same table, why is the source feature type named "coord" when the output is called "Output"?

Perhaps it's as simple as you're just not looking at the correct output table?

Otherwise, you're going to need to add more details, such as whether there is a warning or error message in the log, and what are the parameters of the FeatureWriter.

2
  • the assumption is that he has just created the screen capture for our purposes - Given that he also talks about doing further processing beyond the FeatureWriter transformer.
    – nr_aus
    May 28 at 1:47
  • @Mark Ireland you are right I was just using the wrong output port :-( Thanks a lot.
    – gisgis
    May 30 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.