0

Trying to connect to the PostGIS DB for RiverGIS fails with

Couldn't connect to river database: var@localhost Please, check you database connection settings!

This happens despite the DB being connected to/loaded (see screenshot below) and already having loaded a layer from the DB into the currently open project which I can edit without problem.

What am I missing respective what steps can I take to debug this?

Edit: Having tried answer 1, adjusting the the user & db-name to be same as in the documentation does not solve the problem.

System: Win10 / QGIS OsGEO4W / 3.18.3

I'm aware of QGIS - error connection of database in RiverGIS but there the DB doesn't seem to have been connected to...

Edit: Adjusted screenshots, having tried answer 1: Connection Settings

DB Manager Main

Public Schema

Topological Schema

Message Area of RiverGIS

1 Answer 1

2

According to these documentations - http://rivergis.com/requirements.html - the database name should be rivergis. Your settings have localhost as the server, var as the database and rivergis as the user. Try switching database to rivergis, and using postgres as a username if you're still having issues.

3
  • sorry for the comments mess - am not used to the main window allowing <Enter> for a new line while here in the comment section it means "post it".. Thanks for your suggestion, but unluckily still doesn't work, see the added screenshots in the main post. Anything else I could try? Especially as it seems to be case across different Win10 machines as well?
    – SBerendsen
    May 26, 2021 at 16:40
  • Looks like you're connecting successfully in the first screenshot. What isn't working after that? Are you able to draw the database layers into the layer pane from the browser?
    – Encomium
    May 26, 2021 at 18:29
  • the last screenshot - when trying to connect to it from RiverGIS it fails with the "couldn't connect" error message. And createing, changing, adding and/or removing layers to / from the DB all work flawlessly.
    – SBerendsen
    May 26, 2021 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.