1

I tried to creat a simple GeoPDF in FME. As input in contains just orto + some vector objects. When I open it in AcrobatReader I can see both vector and raster, I am able to check attributes etc. I tried to re-open it in QGIS 3.18 and it says it is invalid data. Both if I try to drag&drop or Add Vector/Raster layers...

I used same data inside QGIS and was able to create GeoPDF. It was still possible to reimport both raster and vector to QGIS.

QGIS is main software in company but unfortunatelly i can't make a workflow that is based on QGIS.

Will be glad for any suggestions! I attatch workflow so it will be easier to undestand Workflow

10
  • Think you need the PDFStyler first before writing see community.safe.com/s/article/creating-pdf-cartographic-output – Mapperz May 31 at 14:55
  • Well I was able to create a PDF with data I wanted. Styler is used (as far as I understand it) to create a layout with title, and annotations + display settings... Anyway - I tried both ways and still it is not possible to reload it to QGIS. – Lynx Jun 1 at 5:39
  • Please post your answer - you will be able to accept your own answer after a time interval. – Mapperz Jun 1 at 13:18
  • When you say "GeoPDF" do you mean that in a generic way or the specific GeoPDF format (by TerraGo)? FME creates "GeoSpatial PDF" - the OGC/Adobe version - but not TerraGo GeoPDFs. I just want to be clear on the expectation here. – Mark Ireland Jun 1 at 14:34
  • 1
    You have to check the "PDF 1.4 Compatible" option in the FME Edit Parameters dialog for an FME-created geospatial PDF to display in QGIS. – Rudy Stricklan Jun 10 at 4:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.