1

I downloaded some land cover maps from Copernicus. I was able to load the .nc layers into QGIS (3.18.3, Windows64) where they displayed correctly, but no CRS appeared in Properties and I was unable to reproject. A question mark appeared next to the layer in the Layers list - on clicking this, I was invited to set a projection, but setting to WGS84 just made the layer vanish. The documentation files (http://maps.elie.ucl.ac.be/CCI/viewer/download/ESACCI-LC-Ph2-PUGv2_2.0.pdf) describe the projection as follows:

The projection is a Plate-Carrée with a geographic Lat/Long representation based on the WGS84 ellipsoid (Figure 3-5). The Coordinate Reference System (CRS) used for the global LC products is a geographic coordinate system (GCS) based on the World Geodetic System 84 (WGS84) reference ellipsoid and using a Plate Carrée projection. The projection makes use of an equatorial radius (also called semi-major axis) of 6378.14 km and of a polar radius (also called semi-minor axis) of 6356.76 km. The inverse flattening parameter is of 298.26 m. The coordinates are specified in decimal degrees. A complete description of the CRS is given in as an ISO 19111 WKT representation. enter image description here

How can I fix this, bearing in mind that I've no experience of coding for QGIS...

2 Answers 2

1

I set both the projection of the NetCDF file and the CRS of the project (in the lower right corner of the QGIS window) to WGS84 and it seemed to be working then.

0

I managed to convert the file into a TIFF in R as follows: in RStudio,

library(ncdf4)
library(raster)
nc_data <- nc_open('C:/Users/ESACCI.nc')
str(nc_data) # to see what slot the map pixels were stored in
# in this case 'lccs_class'
r2 <- raster('C:/Users/ESACCI.nc', varname = 'lccs_class')
writeRaster(r2, 'C:/Users/ESACCI.tif', format = 'GTiff')
nc_close(nc_data)

...after that, I could load the TIFF into QGIS, which assigned it to CRS = WGS84. I still don't know what the point of a NetCDF file is, but never mind...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.