1

How to setup parameter MAP for QGIS Server request, if my project in PostGIS database? "Database path" of project has ampersand:

postgresql://localhost:5432?sslmode=disable&dbname=mydb&schema=myschema&project=myproject

And if I send to URL, QGIS Server can't correctly parse it:

http://localhost:8000?SERVICE=WMS&REQUEST=GetCapabilities&map=postgresql://localhost:5432?sslmode=disable&dbname=mydb&schema=myschema&project=myproject
0

Found a solution. All params can be send throw POST, with x-www-form-urlencoded

0

You need to URL encode your parameter.

Using https://www.urlencoder.org/, this :

postgresql://localhost:5432?sslmode=disable&dbname=mydb&schema=myschema&project=myproject

would give :

postgresql%3A%2F%2Flocalhost%3A5432%3Fsslmode%3Ddisable%26dbname%3Dmydb%26schema%3Dmyschema%26project%3Dmyproject

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.