2

I am working on exporting my maps through the layout editor, but in the generated legend the symbols are not appearing as they should. As you can see from the screenshot, the "Legend Items" displays everything I want it to display, but on the map itself, the circles are missing.

enter image description here

1
  • You can try unchecking "Resize to fit contents".
    – Padmanabha
    Jun 6, 2021 at 5:40

1 Answer 1

3

You can set the symbolization for the legend of the layout in QGIS main window. Either Go to Layer styling panel or Layer properties / Tab Symbology. In both cases, on the bottom, click Advanced and select Data-defined size legend…. Than you can choose e.g. Collapsed legend as shown in the screenshot below.

For details see the documentation.

Settings in QGIS main window / Layer properties: enter image description here

See the result in the layout editor:

enter image description here

4
  • This is great and the symbols came up! The only problem is that they are extremely small in my legend, much smaller than on my map. Is there a way to fix this?
    – Aaron
    Jun 6, 2021 at 21:16
  • Can you post a screenshot, showing the exact same menus etc. as my screenshot? You can edit your original question, paste the screenshot there, than copy the link introduced at the bottom of the edit field (semthing like: i.stack.imgur.com.... ) and than post this link here in a comment.
    – Babel
    Jun 6, 2021 at 21:19
  • 1
    Never mind, I just fixed it, thank you so much for your help!
    – Aaron
    Jun 6, 2021 at 21:25
  • Great, you're welcome!
    – Babel
    Jun 6, 2021 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.