1

I would like to publish INSPIRE compliant WFS service using deegree 3.14.15. deegree is installed using binaries on Ubuntu 20.04 LTS.

I am unable to setup extended capabilities for the WFS service. After uncommenting the proposed extended capabilities section in the example metadata https://schemas.deegree.org/services/metadata/3.4.0/example.xml file I receive a XML validation error.

Error near line -1, column -1: Premature end of file.

I think that something is wrong with namespaces. I have experimented with different contents of ExtendedCapabilities. Following content returns above-mentioned error

<ExtendedCapabilities protocolVersions="2.0.0">
    <inspire_dls:ExtendedCapabilities xmlns:inspire_dls="http://inspire.ec.europa.eu/schemas/inspire_dls/1.0"/> </ExtendedCapabilities>

However, if I change the inspire_dls namespace to any other value, validation works e.g.

<ExtendedCapabilities protocolVersions="2.0.0">
    <inspire_dls:ExtendedCapabilities xmlns:inspire_dls="http://anyothernamespace.com"/> </ExtendedCapabilities>

How can I deal with the problem?

2
  • The following works for me on deegree 3.4.16 <inspire_dls:ExtendedCapabilities xmlns="http://www.deegree.org/services/metadata" xmlns:inspire_common="http://inspire.ec.europa.eu/schemas/common/1.0" xmlns:inspire_dls="http://inspire.ec.europa.eu/schemas/inspire_dls/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://inspire.ec.europa.eu/schemas/common/1.0 http://inspire.ec.europa.eu/schemas/common/1.0/common.xsd http://inspire.ec.europa.eu/schemas/inspire_dls/1.0 http://inspire.ec.europa.eu/schemas/inspire_dls/1.0/inspire_dls.xsd">
    – nmtoken
    Jul 20 at 18:57
  • Note the inspire schema still exist at an HTTP address
    – nmtoken
    Jul 20 at 18:59
0

It doesn't work. First of all, INSPIRE application schema https://inspire.ec.europa.eu/schemas/inspire_dls/1.0/inspire_dls.xsd sets the namespace as

xmlns:inspire_dls="http://inspire.ec.europa.eu/schemas/inspire_dls/1.0"

Secondly, even if I change the schema location to https://inspire.ec.europa.eu/schemas/inspire_dls/1.0/ I am unable to save the service metadata config file, I receive an error

Unable to activate resource: Unable to build resource OWSMetadataProviderProvider:lcv_metadata: Unable to read service metadata config: null

1
  • I have deleted my answer, this answer should be an edit to the question
    – nmtoken
    Jun 7 at 17:07
0

That error may have different root causes. Please try the following:

  1. Check if all deegree configuration files pointing to a INSPIRE schema files do use https as a protocol. Check the issue for more information: https://github.com/deegree/deegree3/issues/1064
  2. Upgrade to deegree v3.4.16 containing PR https://github.com/deegree/deegree3/pull/1131
  3. Apply the following environment variable to the runtime environment, the Apache Tomcat instance for example by setting: javax.xml.transform.TransformerFactory=net.sf.saxon.TransformerFactoryImpl. See issue https://github.com/deegree/deegree3/issues/1110 for more information.
  4. Don't forget to restart Tomcat so that the settings of step 3 are applied.
1
  • Thank you. Now the service metadata file validates. However, when I try to save it I get an error message "Unable to activate resource: Unable to build resource OWSMetadataProviderProvider:wfs_metadata: Unable to read service metadata config: null". It also happens when I try to save without editing WFS service metadata from the imported predefined workspace deegree-workspace-inspire Jun 16 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.