1

I am using QGIS 3.18 to do a quick calculation of the population inside a buffered area. The data for the population comes from WorldPop, the file I got is in the form of GeoTIFF. I inserted it as a raster layer. Then, I put some point type geometries in the map and created a 100 km buffer around the point.

I run the Zonal Statistics tool, The Zonal Statistics then created a new layer, with the categories (sum, mean, etc). But the fields are returned empty (null).

The funny thing is if I do this in QGIS 3.10, the zonal statistics works. Exactly the same settings. The only difference, the stats (sum) is entered directly as a column in the buffer layer, and it contains data. Is this a known bug?

3
  • What about the CRS of the raster and the vector layer before you start the Zonal Statistics? Are both in the same projection?
    – MartinMap
    Jun 8, 2021 at 10:41
  • Yes. I checked and rechecked all CRS. Project, Point, and Raster are in the same CRS. I even, counterintuitively, tried it on different CRS (just to test), also doesn't work.
    – necrohiero
    Jun 8, 2021 at 10:42
  • Check the band of the raster you are using for this tool.
    – Michal De
    Jun 8, 2021 at 12:16

2 Answers 2

0

Check your CRS.

This tool require a Projected CRS.

WGS84 doesn't work

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 23, 2021 at 11:21
-2

Try "Raster statistics for polygons" from Saga tools. It work's fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.