1

I'm currently working with Natural England layers provided on data.gov. The WMS layers display where they should for EPSG:27700, but the added WFS layers do not. When zoomed out to show the extent, they appear to be rotated and in the wrong place. How do I fix this error?

https://environment.data.gov.uk/spatialdata/sites-of-special-scientific-interest-units-england/wms

https://environment.data.gov.uk/spatialdata/sites-of-special-scientific-interest-units-england/wfs

I have tried using other EPSG and have also tried to load into Golden Software's Surfer and have found that the same happens there.

3
  • 2
    Which CRS did you use when loading the WFS? Which CRS does it support? Which CRS did you try? – Erik Jun 8 at 12:23
  • which version of WFS did you use? – Ian Turton Jun 8 at 13:11
  • Welcome to Geographic Information Systems! Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works – Ian Turton Jun 8 at 13:11
0

Found the answer for anyone who needs it. You need to modify the connection and select the invert axis orientation at the bottom. Then you need to restart QGIS. I had tried all but reloading, and it hadn't worked then.

1
  • 1
    While this is a work around you should report that the server is returning the data with the incorrect axis order (EPSG:27700 is well defined as E-N and it is returning N-E, which is easy to check as they include easting and northing in the atributes) – Ian Turton Jun 8 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.