4

In my legend I have one layer with a group heading and due to layout reasons I need it to be split in 2 columns:

enter image description here

The only work around I can think of is to set heading to '' either in the layer panel which is ugly and results in a even quirkier legend layout or doing so in the legend item properties in the print composer which has no impact at all.

I am using QGIS 3.18.3

4
  • I suggest you add a picture of what you would like to achieve. Or would it be sufficient to simply remove the group header?
    – Erik
    Commented Jun 8, 2021 at 13:34
  • Technically a group header can't be removed but set to an empty string and the two possibilities to do so don't work out as expected just as i wrote in my question.
    – maxwhere
    Commented Jun 8, 2021 at 13:37
  • 3
    Rightclick the group in the legend item properties, set it to hidden - and it is removed from the legend.
    – Erik
    Commented Jun 8, 2021 at 13:41
  • That 'hidden' option is exactly what I was looking for! Thank you very much!
    – maxwhere
    Commented Jun 8, 2021 at 14:43

1 Answer 1

7

The style you are expecting is only possible with the legend title.

To do so you have to:

  1. Hide the group header (like @Erik explained)
  2. Set the title of your legend to be "Housing Area"
  3. Set margin around title and font of your title to get the result you are waiting for.

Note: Here there is a question that may give you more information about vertical alignment: Vertically and Horizontally align the labels in multi-column QGIS legends

2
  • Actually I was aware of that question you linked but its answer doesn't make use of that very option. Also I didn't dive into that OP's issue since its complexity seemed way beyond my problem here but now I bookmarked it. Anyway many thanks for your answer!
    – maxwhere
    Commented Jun 8, 2021 at 14:52
  • Fine if it work. The question linked was only to give more info about vertical align rules. Commented Jun 8, 2021 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.