4

TLDR: What I want is best explained by the pictures below.

In words: I have partially overlapping features and I want to visualize this overlap with transparency. I know I can set a Layer Properties > Display > Transparent value, but this will only make the whole layer transparent, not the actual features.

What I get (33% transparent layer, the overlap doesn't show): 33% transparent Feature Layer, where overlap doesn't show

What I want (features within one layer, transparent "among themselves", showing overlap) Transparent features show overlap between features

Obviously I could make a layer for each feature and use Layer transparency, but that is not an option for >22'000 features.

I achieved the latter picture by using Layer Properties > Symbology > Advanced > Transparency (see below), selecting (somewhat randomly) the ID as the required "transparency attribute/field". This makes some features transparent, others not... probably a high ID gets a high transparency? I haven't figured out the logic, I also tried adding a new attribute/field "transparent" filled only with a value 33, to use this as "transparency field" (=33% transparency), however this doesn't work at all (features within one layer are still "not transparent amongst themselves"). I also added in one row with 0 and one row 100, leaving all others at 33, hoping that transparency is scaled to the value range. Both didn't work. Anyway, all this feels like a hack. I was hoping I could make the feature color transparent (e.g. as in QGIS), but can't see an option to do so. Using a transparent texture (e.g. lines) also doesn't work, since the lines are perfectly aligned, not showing overlap either. Is there a proper way to do this?

showing Layer Properties > Symbology > Advanced > Transparency

1
  • If you want to use "transparent texture" like line fill you will need to vary the offset and/or the line angle for each symbol so the line didn't superpose. As you seem to work with lots of symbol this is not optimal and may get not very aesthetic. Use this only if @Hornbydd solution didn't work for you
    – J.R
    Commented Jun 9, 2021 at 16:27

1 Answer 1

5

You need to set the symbol level, see video below on how to achieve the transparency you desire.

Video

1
  • cool, that was the missing step to get the "hack" going :] thanks! However: first materializing a field for the sole purpose of visualization still doesn't seem like good practice to me. I'll wait a bit, maybe there is a more elegant solution...
    – Honeybear
    Commented Jun 9, 2021 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.