0

I had tried to run the 'Difference algorithm' on two layers. However, the process constantly fails with a "GEOS geoprocessing error: difference failed" message. When I tried running an intersection, it also returned the same error. There are no further details given, and I tried fixing geometries with both 'Check geometries' and 'Fix geometry' tools.

Both layers are clean when I check their validity.

0

The solution lay in how one of the layers was made, as it was created by the union of two other layers. This may have led to duplicate polygons or multipart objects, so I ran the multi-part to single-part tool (Vector>Geometry Tools>Multiparts to Singleparts) on the layer. I was then able to run the difference tool and it worked. (seems simple, but it took up so much time I think this is worth explaining).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.