1

I got Warning 000117 - Warning empty output generated while trying to import a CSV to the ArcGIS Pro geodatabase. I have cleaned the file to remove obvious problems -- changing NA and NaN cells to 0 and removing all special characters from field names. I still get Warning 000117. I've also tried using a short version of the same file -- a few thousand record instead of 500,000 records -- with the same result.

File has 18 columns: one text (coerced from numeric) and the rest double. Field names are: BLOCK2020, Totpop, NHWhite, NHBlack, NHAmInd, NHAsian, NHPacIsl, NHOther, NHMulti, Hispanic, HUTotal, HUOcc, HUVac, NHWhitePer, NHBlackPer, NHAsianPer, HispanicPer, and NonWhitePer.

Note: I want to import directly to the geodatabase rather than to a folder so I can specify the datatype of the BLOCK2020 field. If I import it through the folder, the Block comes in as numeric, and several states with leading zeroes in their block ID's have to be manually corrected after import - a huge pain.

1
  • It will also make text field 8000 ! Long. Go through Access perhaps
    – FelixIP
    Commented Jun 24, 2021 at 20:42

1 Answer 1

0

Partial answer: The default length for text columns is 8. I changed it to the actual length of the census block ID, 15, and the import worked. But although I specified text, Arc truncated leading zeroes from the block ID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.