3

I may well be missing something very easy, but how do you connect an algorithm in the QGIS graphical modeler to the Input?

I'm following an online tutorial and have added the Inputs into the Model; when i select the first Algorithm, complete the details for it (including the Input it needs to be connected to) and click OK, the algorithm appears but no connecting line.

Am i doing this correct, or is there something else i need to do to make the connection?

I'm using QGIS 3.16.8.

ScreenshotScreenshot of modeller window should be below

The tutorial i'm following is: https://www.qgistutorials.com/en/docs/3/processing_graphical_modeler.html

1
  • Can you add a screenshot?
    – Babel
    Jun 26, 2021 at 9:49

1 Answer 1

1

For input layer, set Use model input, not the default value option.

Model Input: choose this option if the parameter comes from an input of the model you have defined. Once clicked, this option will list all the suitable inputs for the parameter

https://docs.qgis.org/3.16/en/docs/user_manual/processing/modeler.html?#definition-of-the-workflow

enter image description here

2
  • Thanks for your answer, much appreciated!
    – Simon Hume
    Jun 27, 2021 at 16:49
  • Has anyone had the model input drop down empty? This is happening to me.
    – dgketchum
    Dec 28, 2022 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.