0

I've created a polygon feature. When I go into "Edit" and then "Create Feature" however, I am unable to draw a polygon that gets saved to that feature. The polygon disappears as soon as I hit 'finish' and seems to get assigned to a line segment in a different place. I've checked to make sure I'm using the same coordinate systems across all my features/map so I don't think that is the problem. In the attribute table, there are shapes listed but they are all lines with Shape Area = 0. I've attached screenshots of the process below. I've created polygons so many times in ArcGIS, so I'm so confused why I can't do it in ArcGIS Pro. I've checked this similar post and it hasn't helped Polygon disapears after finishing edit in ArcGIS Pro.

What is going on here? 

Step 1: Create polygon

enter image description here

Step 2: Hit "finish"

enter image description here

Step 3: Polygon disappears?!?!

enter image description here

Attribute Table

enter image description here

4
  • Seem obvious but have you check that you are not drawing a part of a multipolygon ,that you don't have any definition query or that your symbology didn't make your polygon invisible ?
    – J.R
    Jun 30 at 15:47
  • There is no definition query, the symbology is set for everything to be a specific color and when I turn off all the other layers and basemaps, it's still not there. I'm not sure about the multipolygon part, but I set it up as a polygon feature class and am definitely not using the 'multiple polygons feature builder' tool in Arc. Jun 30 at 20:38
  • Does the newly polygon appear in the attribute table ?, also what do you mean by "it seems to get assigned to a line segment in a different place"
    – J.R
    Jul 1 at 9:08
  • A new shape appears in the attribute table that has a length, but not an area (which I believe indicates it is a line, even though it is marked as a polygon). Additionally, its difficult to see in the pics, but a bright blue line pops up above where I built the polygon when I hit finish. When I highlight it in the attribute table, I see it's the exact same line being built every time I create a new polygon. Jul 1 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.