3

This is a bit of a weird question, but I recently switched from a PC to a Macbook (with a latin keyboard) and I cannot figure out the shortcut to comment/uncomment text in the Code Editor.

On the PC it used to be Ctrl+/, and according to the Code Editor shortcut menu on Mac it should be +/, but doing that does not work. I tried +Shift+7 (that's where the forward slash is located on the laptop keyboard), Command+7, Ctrl+7, Ctrl+Shift+7, and also tried +/ using the numeric pad of a bluetooth keyboard, but neither worked. Has anyone figured this out?

For anyone wondering, this is my keyboard setup:

enter image description here

3

3 Answers 3

1

I had a similar problem with Windows and Linux, using a Portuguese Brazilian keyboard. Maybe my solution can help you as well.

For me, Ctrl+/ didn't work but Ctrl+; worked (I don't know the reason but can be related to the keyboard type, as mine is similar to yours). I also found that both shortcuts didn't work in Mozilla Firefox, just in Google Chrome and Opera. I didn't test in Safari, Edge and others. If you are not using Google Chrome and using ; in place of / don't work, try switching your browser as well.

Please, let me know if it worked.

2
  • No unfortunately it did not work, even though I am using Chrome also. Tried clicking buttons at random too accompanied by either Ctrl or Cmd, which unsurprisingly did not work either, haha.
    – M. Nicolas
    Nov 3, 2021 at 22:42
  • Oh no! It's a pity. Looks like we can only wait till Google fixes it, hope it doesn't take too long (more than you already waited). Nov 4, 2021 at 0:36
0

I also couldn't use Ctrl+/, but Ctrl+# worked for me.

1
  • Didn't work either, I think because to type # on this keyboard you have to type Option + 3
    – M. Nicolas
    Nov 17, 2021 at 18:09
0

For me, using windows 10 and a swiss keyboard setup it is

Ctrl + °

That works. No idea why, but I'm glad to have found it.

2
  • I used it and it worked Ctrl + ° That works.
    – raul pedro
    Jul 11 at 4:02
  • No luck either :(
    – M. Nicolas
    Jul 19 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.