0

On recent GeoServer versions 2.18 and above, Python community module is no longer appearing for download on https://build.geoserver.org/geoserver/ Is there a way to download and install this scripting extension on recent GeoServer versions? This was a very useful plugin.

We can continue to see it described on the official documentation https://docs.geoserver.org/latest/en/user/community/scripting/installation.html but the file no longer exists for download.

1
  • That looks like a bug in the documentation deployment - you'll note that page is linked to anything any more but doesn't seem to have been deleted.
    – Ian Turton
    Jul 2, 2021 at 9:52

1 Answer 1

2

History: Unmaintained since a while so removed with https://github.com/geoserver/geoserver/pull/4670

You need to dive into the code to make a version compatible for latest GeoServer on your own and become the maintainer if really interested.

To get the latest code source that contains the code, look at this particular commit https://github.com/geoserver/geoserver/tree/8109b626843b0ca7d4282b86c4589a64be62310e/src/community/script

Sorry for the bad news...

1
  • This was discussed on the mailing list and no users spoke up - so remember to join the user list if you want to avoid being the last to know
    – Ian Turton
    Jul 2, 2021 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.