6

Since I installed the new OSGeo4W installers for the 3.16 version around 2 weeks ago, my QGIS is sooo slow! No matter which installer I used (I tried the old and the new OSGeo4W network installer and the old and new standalone-versions), the program needs a long time to start and working with QGIS is almost not possible because it is so slow. Before I installed the new versions, I always made sure to delete the old versions. However, the plugins, profiles and favourites are still in the new versions, which I don't understand. I have a Windows 10 machine and 96 RAM and an Intel i7 2.6 GHz processor. Two questions:

  1. How can I make sure, that I deinstalled QGIS properly including all profiles, plugins and favourites?
  2. What could be the reason for the bad performance and how can I speed up my QGIS performance?
7
  • Which QGIS version? What plugins have you enabled?
    – Stu Smith
    Jul 7, 2021 at 5:53
  • I tried all current versions of 3.16 Jul 7, 2021 at 6:00
  • Try de-activating all plugins
    – Babel
    Jul 7, 2021 at 6:04
  • de-activating or de-installing? Jul 7, 2021 at 6:09
  • I de-installed all plugins but this didn't have any impact on the performance Jul 7, 2021 at 6:15

1 Answer 1

12

First, I would try with a fresh profile. Go to Settings -> User Profiles - New Profile. This is basically like a fresh QGIS install - no Plugins are loaded, no (maybe wrong) settings you changed are there etc. If this makes QGIS launch again in normal speed, carefully install your needed plugins one after one to determine which could cause the slow down!

If this does not help, often a faulty network drive is the problem. Can you check in your Windows file browser if all drives are active? Click on each of them to make sure of it. If you have inactive network drives, hiding them in QGIS file browser should do the trick:

You can (inside the file browser panel of QGIS) right click the drive and "Hide from Browser"

OR

(according to this answer: https://gis.stackexchange.com/a/391072/78414) go to C:\Users\*UserName*\AppData\Roaming\QGIS\QGIS3\profiles\default\QGIS\QGIS3.ini and add the drives you want to hide like this:

[browser]

hiddenPaths=Q:/, S:/, T:/, U:/, V:/
7
  • 1
    so have you tried to close the QGIS file browser and restart QGIS?
    – sn1ks
    Jul 7, 2021 at 10:34
  • 1
    Thanks! I closed the browser window, restarted QGIS and now it seems to work! At least for the last 5 minutes ;) Jul 7, 2021 at 11:31
  • 2
    ok, so if you want your browser back in QGIS (and have a fast QGIS anyway) just right click and hide those network drives which are inactive
    – sn1ks
    Jul 7, 2021 at 13:00
  • 1
    The inactive network drives where indeed the problem! Thank you for your help! Now I am trying to figure out how I can work for different customers with QGIS, which means from time to time I need those network drives. I probably have to activate / deactivate and hide / unhide them each time I switch from one QGIS project to the other... Jul 12, 2021 at 9:57
  • 2
    no, i would advide you to create different profiles, one for each customer. there you can hide those drives you don't need and leave the ones you need unhidden. switching user profiles seems easier i think :)
    – sn1ks
    Jul 12, 2021 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.