0

When using QField sync I get the following error message but I'm a GIS novice and cannot make out where the problem lies.

An error has occurred while executing Python code:

IndexError: list index out of range Traceback (most recent call last): File "C:\Users/User/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\qfieldsync\core\offline_converter.py", line 381, in on_offline_editing_next_layer msg = self.trUtf8('Packaging layer {layer_name}…').format(layer_name=self.__offline_layer_names[layer_index - 1]) IndexError: list index out of range

Python version: 3.9.5 (tags/v3.9.5:0a7dcbd, May 3 2021, 17:27:52) [MSC v.1928 64 bit (AMD64)] QGIS version: 3.16.8-Hannover Hannover, 8c50902e

Python Path:

C:/PROGRA~1/QGIS31~1.8/apps/qgis-ltr/./python
C:/Users/User/AppData/Roaming/QGIS/QGIS3\profiles\default/python
C:/Users/User/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins
C:/PROGRA~1/QGIS31~1.8/apps/qgis-ltr/./python/plugins
C:\Program Files\QGIS 3.16.8\bin\python39.zip
C:\PROGRA~1\QGIS31~1.8\apps\Python39\DLLs
C:\PROGRA~1\QGIS31~1.8\apps\Python39\lib
C:\Program Files\QGIS 3.16.8\bin
C:\PROGRA~1\QGIS31~1.8\apps\Python39
C:\PROGRA~1\QGIS31~1.8\apps\Python39\lib\site-packages
C:\PROGRA~1\QGIS31~1.8\apps\Python39\lib\site-packages\win32
C:\PROGRA~1\QGIS31~1.8\apps\Python39\lib\site-packages\win32\lib
C:\PROGRA~1\QGIS31~1.8\apps\Python39\lib\site-packages\Pythonwin
C:/Users/User/AppData/Roaming/QGIS/QGIS3\profiles\default/python
C:\Users\User\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins\DigitizingTools\tools
C:\Users\User\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins\DigitizingTools
C:/Users/User/Documents/Qfield_import

I initially used an older version (3.10) but using this version doesn't solve the problem.

10
  • Can you let us know which version of the QFieldSync plugin you have installed? – Matthias Kuhn Jul 13 at 5:14
  • Another message I get is "the data has been synchronized successfully but the original project could not be opened" – user188161 Jul 13 at 8:08
  • If I try to save the project & close "unable to perform zip" appears. I had hoped that saving, closing and then reopening the project would solve the issue – user188161 Jul 13 at 8:12
  • @MatthiasKuhn I have the 3.4.4 plugin installed. When I open what I think is the original project & sync – user188161 Jul 13 at 8:16
  • Can you install github.com/opengisch/qfieldsync/releases/download/v4.0.0-beta7/… (as zip file from the plugin manager)? – Matthias Kuhn Jul 13 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.