2

Basically, I have a CSV table with lat/long coordinates that I am trying to upload onto a map. However, when I "add text delimited layer" it puts the spots in the completely wrong location. I put the map and the table below.

The points (there are 4 of them even though they look like only one) should be in Antarctica, but they show up in the middle of the map. I have tried this with both the WGS 84-Psuedo Mercator projection (used by Google Earth satellite), and the WGS 84-Antarctic stereographic projection (used by Quantarctica).

In both cases i made sure the coordinate systems aligned. Could there be something wrong with my csv table, wrong format or the like? I am pretty sure I got the decimal degrees right. I know I can do the Google Earth > KML file trick but I would like to have everything on one table for easy viewing.

the red dot is where the coordinates get dropped

the table i have lat/long stored on

2
  • 3
    you probably entered your lat column as X and lon as Y. They are y,x respectively
    – Llaves
    Jul 15 at 1:54
  • 2
    Where are you expecting your data to be placed> South Pacific Ocean?
    – Mapperz
    Jul 15 at 3:20
5

Your problem is that you set the wrong CRS - probably the most frequently asked question here on GIS SE. Your coordinates are interpreted in the wrong CRS definition. See here for details why your points fall on the Null island.

For lat/lon coordinate values, use EPSG:4326 as layer CRS. Set this CRS in the import dialog (see screenshot 2) or right click your imported layer, click on Set layer CRS and select EPSG:4326 (screenshot 1).

You wrote you "tried" WGS 84-Pseudo Mercator and WGS 84-Antarctic stereographic. But none of them uses lat/lon coordinates that your coordinates are in. The imported coordinate values must be assigned to the correct layer CRS to be interpreted correctly.

If you want to show your map in Antarctic Polar Stereographic projection, set the project-CRS to EPSG:3032 (or 3031). See here for the difference of project- vs. layer CRS

Screenshot 1: setting the right CRS of the layer QGIS Project CRS vs. layer CRS

Screenshot 2: setting the right CRS when importing enter image description here

1

Your points are plotting at "Null Island", which is the intersection of 0 latitude and 0 longitude. Hence you can be sure the import has not picked up the spatial geometry correctly. As to why, a possibility is that you imported csv text file without specifying geometry, or that you chose the wrong columns, or that the columns are being picked up as text rather than numeric. You might have to share some data or give more information to clarify this.

0

What worked for me was to ensure that longitude was reading as X and latitude was reading as Y. I had it flipped around before (lat/long vs long/lat).

-4

Have a look at your coordinates. Both lat and long are negative.

Lat of less than 0 is south of the Equator, Lat more than 0 is north

Long less than 0 ... never seen that before.

I would suggest that you use your favourite spreadsheet to change the long coordinate to a positive number and try again. Make sure you use the correct CRS when you import to QGis

2
  • 2
    All longitudes west of Greenwich around to 180W are interpreted as negative. For example southern tip of South America- approx -65 Longitude -54 latitude. Jul 15 at 5:05
  • As I say - I had not run into that notation before. Thanks for helping out
    – FPG
    Jul 19 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.