I know this has been asked and re-asked, but I can't seem to get any of the proposed solutions to work. Upon clicking the start menu shortcuts to QGIS desktop, nothing happens. When I run from command prompt, I first received the error that "qwt5.dll" was missing. This was installed and present in the Quantum GIS Lisboa/bin folder, and I copied it into the QGIS app/bin folder, along with the next series of dll's it said were missing. It then told me it could not find PyQt4, and then that the SIP module was missing and that python would be disabled. I ensured that the paths were included in my environment variables, but no change. I was curious if the existing versions of PyQt4 (and the accompanying SIP module) that were already installed on my computer could be the cause of this?

This is on my work machine which has heavy security measures in place. On my home machine, which also had PyQt4 and SIP installed previously, I had no issues with installation or launch. Both machines are 32-bit Windows 7. Does anyone have any ideas?

EDIT: After much, much screwing around with paths and bat files, I got the desktop, browser, GRASS and MSYS to launch. I still cannot launch OSGeo4W.... when I run the bat file in command prompt, I first got "findstr not recognized".... copied, pasted, re-ran... got "_path=C:/Apps/QGIS//apps/Python27/scripts find: .exe no such file or directory, find: .bat no such file or directory "........hmm..

  • 1
    Do you have local admin on your works window7 box? right click 'run as administrator' should work. (With QGIS 1.8 the only issue I have (at work) is when I close it crashes and closes.))
    – Mapperz
    Nov 6, 2012 at 15:18
  • related gis.stackexchange.com/questions/16583/…
    – Mapperz
    Nov 6, 2012 at 15:20
  • I have, I installed as admin and ran as admin...no luck Nov 6, 2012 at 15:22
  • It is not retrieving any of the .dll's from the main bin folder... Nov 6, 2012 at 15:32
  • 1
    Is QGIS installed in Apps or Program Files? - might be a permissions setting on that folder.
    – Mapperz
    Nov 6, 2012 at 15:40

2 Answers 2


I guess you have installed the standalone installer. Try the OsGeo4W installer, which installs to C:\OSGeo4W. That will give you no conflicts with spaces in folder names.

Also, rename the folder of your existing Python and PyQt temporarily to make sure you start the right python. Starting of Osgeo4W programs has to be by using the bat files, not the exe's. In the bat files, necessary environment variables are set.

And, by the way, Qgis is running here on Windows 7 with no need for screwing up. Even python 7 installed in parallel, but not PyQt. Most likely PyQt and Qgis interfere at your computer.

  • Thank you! I'm not sure what the deal is with PyQt-- both function fine on my home machine, same versions and everything. At least I got QGis Desktop working! Nov 7, 2012 at 18:04

It seems that PyQt4 does not like the space in "Program Files" on Windows 7

Reinstall QGIS in the apps location


Try installing QGIS in a folder without the spaces

  • Argh.... tried it. No luck, still receiving the same "missing dll" errors Nov 6, 2012 at 16:59
  • Copied all DLL's again, got the splash to show up, gets to "starting python" and then disappears.... Nov 6, 2012 at 17:11
  • if I try to run any other .exe I get some .dll or other missing. I have added the bin folders to path, so I'm not sure what's going on. I uninstalled PyQt and re-installed QGIS, same problem. Nov 6, 2012 at 17:56
  • This did the trick for the QGis desktop, at least, thank you. Nov 7, 2012 at 18:05
  • Your welcome glad it solved your issue with desktop QGIS.
    – Mapperz
    Nov 7, 2012 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.