I have a layer with locations. I want to display this on a layout that has a map at a small scale (main map) and an inset map at a bigger scale. I do not want to show on the main map the symbols that appear on the inset map.

From what I have read, I should use rule-based symbols and make them not show at a smaller scale, but that would affect all the symbols, including the ones that I do want to show on the main map. How do I limit it to those that appear on the inset map?

The locations that I only want to show on the inset map are "marked" as explained here Removing labels from area that is also shown on inset map with QGIS

Create a new attribute called label with field calculator and set it's value to 0 for the selected ones (where labels should be hidden on the main map), to 1 for all others (where labels should always be shown).

Related links:

The picture shows what I want to achieve.

enter image description here

  • 1
    If you use rule-based symbology with both scale + your marking as indicated in the previous questions ... why would that not work ?
    – Snaileater
    Commented Jul 19, 2021 at 6:56
  • I'm not saying it would not work, I just don't know how to do it. If I go to Layer styling > Labels > Single labels > Rendering > Show label, I can filter which ones I want to show, but I cannot find an equivalent menu for symbols.
    – user188574
    Commented Jul 19, 2021 at 7:29
  • Layer Styling/ Symbology / Rule-based ... and then set your rules up as indicated in the previous questions ...
    – Snaileater
    Commented Jul 19, 2021 at 7:51

1 Answer 1


For you map without symbols, go to the map window and turn of any layer you do not want in the map without symbols. Now go the the composer window and click on item properties for that map and in the "layers" section, tick "Lock Layers".

Then go back to your map window and turn on the layers you want in your other map. Then lock those layers if you wish.

  • All the symbols are in the same layer, if I turn it off no symbols appear at all.
    – user188574
    Commented Jul 19, 2021 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.