1

So I have a filtered shapefile layer with only 2 records:

enter image description here

I use dissolve tool, selecting all fields, since I have tried different combinations

enter image description here

Yet, final attribute table of dissolved image still shows same number of records, when I expect only one register

enter image description here

I have tried different ways to do it, but it always returns same number of previous records. There must be something wrong the way I do it, since in many tutorials no problem like this is shown (they usually dissolve based only on one field, which I have tried, no good results at all), what is wrong in here?

0

1 Answer 1

2

From the documentation (emphasis mine):

Dissolve

Takes a vector layer and combines its features into new features. One or more attributes can be specified to dissolve features belonging to the same class (having the same value for the specified attributes)

So don't try to dissolve using fields with different values, unless you don't want those records merged.

It looks like (but I can't be sure as some fields are larger than shown in your screenshots) TIPO_TRANS, RUTA_CORRE, DETALLE and DESCRIP contain the same values for both records, so dissolve on those fields, not on ID or DETALLE_2 as those fields have different values.

1
  • Thank you so much. This worked really well! I never saw those details, in documentation.
    – John Doe
    Commented Jul 26, 2021 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.