1

Unfortunately my QGIS doesn't really want me to change the Projection of the OSM Vector data. I downloaded processed Vector OSM Data which was in the (normal) Mercator Projection. I put the layers in QGIS and reprojected everyone of them separately in the same cartesian system (EPSG: 32632) and set the Project EPSG 32632. Then I saved the files to be sure everything is in the new projection. When I open the files however everything looks fine until I try to put a buffer around a POI or something else. It looks like the extension of my layers is like 50 centimetres now which cant be because the area I am working with is around 300km extended (minimum). When I use the original (unreprojected files) everything is in perfect order, but I want to use it in UTM since I want to work with exact distances and metres/kilometres. Is it the files or did i reproject wrong (which I doubt since ive done it quite a few times and this never happened). I already tried reopening QGIS or reprojecting it again and I had the same issue. enter image description here

4
  • We definitely need more details on this. How did you reproject? What distance did you buffer your reprojected data with? Can you provide a screenshot of the issue?
    – Erik
    Commented Jul 27, 2021 at 9:46
  • how did you reproject the data?
    – Ian Turton
    Commented Jul 27, 2021 at 10:25
  • i have multiple layers e.g. osm_places, osm_pois etc. I opened them in QGIS. switched the EPSg in the bottom right corner to 32632, right clicked on the layer i wanted to reproject --> then on set crs --> set layer crs --> EPSG 32632. After this i went on export --> save feature as --> saved it as a shapefile in destined folder and reopened it.
    – user189028
    Commented Jul 27, 2021 at 10:32
  • 1
    Setting the CRS is not reprojecting. Hence your whole workflow is faulty.
    – Erik
    Commented Jul 27, 2021 at 13:41

1 Answer 1

1

Try this:

Right click on layer to be reprojected -> Export -> Save Feature As... -> Change CRS to whatever you need (see screenshot below)

This should actually reproject your files - just setting it will not reproject, it will assume your file is in this CRS already and just interpret it using the new CRS.

screenshot export in new CRS

1
  • Thank you very much i made it now! :)
    – user189028
    Commented Jul 30, 2021 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.