0

I have been trying to load WMTS layer from bhuvan portal in QGIS. The WMS layer works fine but the problem lies in WMTS layer and it shows me the following error:"Failed to download capabilities: Download of capabilities failed: Error transferring https://bhuvan-vec2.nrsc.gov.in/bhuvan/gwc/service/wmts/?SERVICE=WMS&REQUEST=GetCapabilities - server replied: 400" the url is : 'https://bhuvan-vec2.nrsc.gov.in/bhuvan/gwc/service/wmts/'

the layer is: 'geomorphology:WB_GM50K_0506'

I have also followed the following link from the official document of QGIS in the mentioned link :https://docs.qgis.org/3.16/en/docs/user_manual/working_with_ogc/ogc_client_support.html

Is it the problem of bhuvan link or something else?

4
  • 1
    The url to the capabilities xml is not correct. Do you have a link to the bhuvan support site that describes how to download the capabilities document, so I can have a look?
    – scott_f
    Jul 28, 2021 at 4:37
  • 1
    It seems the administrator has "broken" something and GWC needs to be synced to GeoServer
    – Ian Turton
    Jul 28, 2021 at 8:25
  • @scott_f I am sorry but I couldnot find anything as such which describes it.
    – Boni
    Jul 29, 2021 at 6:10
  • @IanTurton Can you help me a bit more as I am completely new in this. is it something like we have to publish it in geoserver and then fetch the tile on open layers?
    – Boni
    Jul 29, 2021 at 6:11

1 Answer 1

1

I agree with the comment of @IanTurton. I believe there is something wrong with the Bhuvan WMTS server.

I have tried to connect to the Bhuvan in QGIS and I get the same issue.

I found videos demonstrating how to connect using QGIS:

(2015): https://www.youtube.com/watch?v=0098p61dQuM

(2020): https://www.youtube.com/watch?v=EsBoH3Ji3HA

Steps:

  1. In QGIS on a new WMTS connection.
  2. Enter: https://bhuvan-vec2.nrsc.gov.in/bhuvan/gwc/service/wmts/ as the URL in the New Connection dialog.
  3. Enter a Name for the connection.
  4. Click Ok. Click Connect in QGIS and it should download the capabilities document. However something is wrong.

When I try the same steps it doesn't work for me either. Perhaps you can look up a number to contact them directly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.