3

I'm running into a problem once I try

[cmake_dir]/bin/cmake .

I get these errors:

Boost headers were found here: /usr/include
Output directory for libraries is set to sh: /usr/bin/postgres/pg_config: Not a directory
Installation directory for libraries is set to sh: /usr/bin/postgres/pg_config: Not a directory and for SQL files is set to /usr/share/pgrouting
-- Configuring done
-- Generating done

I'm running CentOS 6.3 and all I know is that my postgresql data folder is at /var/lib/pgsql/data

2 Answers 2

1

You also had a similar error and to resolve it I made a modification in the CMakeCache.txt file. Look at the line which contains POSTGRESQL_EXECUTABLE:FILEPATH and update with your real postgresql filepath.

Hopefully it will help you

1
  • jesus christ, my file PATH was an error message (with no self-explanation that this is the default setting). Thanks a lot pgrouting guide, you never mentioned that **** Sep 10, 2013 at 2:33
1

Building on baudinseb's answer, I changed my POSTGRESQL_EXECUTABLE:FILEPATH from POSTGRESQL_EXECUTABLE-NOTFOUND to /usr/bin. Found that using which psql.

Anyway. Also installed postgresql-server-dev-9.1 with apt-get. I'm on to the next step.

Shame on somebody for this. How on earth could you set up an install package to FAIL NO MATTER WHAT and leave NO REASONABLE NOTIFICATION to your user that you have done so. WHY THE ** DOESN'T THIS DEFAULT TO UBUNTU/apt-get default paths? Regardless, "POSTGRESQL_EXECUTABLE-NOTFOUND" looks like a species of error message, not a "friendly reminder" to set the path. A simple error message for this situation would go a long way.

Anyway, congratulations on attempting to cross the rubicon that is installing pgrouting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.