I have digitized three rivers on Google Earth and converted into shapefile to use in MATLAB. I have checked the shapefiles in ArcGIS and they are working. But while opening in MATLAB, it shows the following errors:

Unsupported shape type PolyLineZ (type code = 13).

headerTypeCode = readHeaderTypeCode(shpFileId,callingFcn);

The code I am giving is below:

water = shaperead('rivers', 'UseGeoCoords', true);
geoshow( water , 'Facecolor', 'blue')

closed as unclear what you're asking by Aaron Oct 7 '16 at 1:55

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    It would seem Matlab can't cope with 3D polyline shapefiles (which is what PolylineZ type represents). Convert the shapefile to 2D only, and if you need the elevation data, add it as an attribute, not actual geometry data – U2ros Nov 8 '12 at 9:29
  • @U2ros yes....you were right..it solved the purpose...but the next problem is the area which i specified in my program and the area inbuilt in the matlab for Russia are not matching.....may be due to projection system problem...i have used Lambert projection system..Can you suggest me something..?? – Prateek Verma Nov 19 '12 at 10:54
  • Which Lambert exact projection are you using, they may have different properties – U2ros Nov 19 '12 at 11:18
  • @U2ros i am using Lambert Conformal conic projection. I searched in the net and somewhere i found this projection is used for Russia. – Prateek Verma Nov 20 '12 at 10:01
  • 1
    Check out this link: chatt.hdsb.ca/~vanelliss/FOV1-000B9892/FOV1-000B9932/… Your are looking for an equal-area type of projection. There are no concrete projections listed there, but when you choose a type you should find one in the list of available SRSs – U2ros Nov 20 '12 at 10:50

In ArcGIS, use the tool Copy Features

select "Environment", then select Z Values, "disabled"

Do the same with M Values to be sure. The resulting shape file should open in Matlab.

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.