0

I'm using GDAL 3.3.1 on Windows 10 through Anaconda. I'm trying to convert a TIMESAT binary file to a .tif, which I've been able to do before. However, when I enter this code:

gdal_translate -of GTiff C:\timesat33\run\01 corners\01tl\01tlamp_season1 01tlamp_season1.tif

I get the error message

ERROR 6: Too many command options '01tlamp_season1.tif'

followed by a list of usage options. I'm not sure why this isn't working, since this code worked for a different file:

gdal_translate -of GTiff C:\timesat33\run\1315sos_season1 1315sos_season1.tif

Why do I get this error?

2
  • 2
    The spaces in the path are the issue. Is the first input C:\timesat33\run\01 or C:\timesat33\run\01 corners\01tl\01tlamp_season1??
    – Mike T
    Jul 29 at 23:08
  • @MikeT That worked! Thank you, I wasn't aware that spaces aren't allowed in Anaconda.
    – Beck
    Jul 30 at 13:04
0

This was said by Mike T in the comments, but I can't add that as the answer to the post. The issue was the space in ...\run\01 corners\..., and has been remedied by changing it to ...\run\01corners\....

1
  • 1
    It should work also as gdal_translate -of GTiff "C:\timesat33\run\01 corners\01tl\01tlamp_season1" 01tlamp_season1.tif.
    – user30184
    Jul 31 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.