0

I made a WMS host with AWS. The WMS work with link below

localhost:8080/geoserver/OSM/wms?

But I'd like to reach it out of the network with this link and QGIS:

http://ec2-xxx-xxx-xxx-xxx.us-east-2.compute.amazonaws.com:8080/geoserver/OSM/wms?

Failed to download capabilities

This is also not work: http://ec2-xxx-xxx-xxx-xxx.us-east-2.compute.amazonaws.com:8080/geoserver/ows?service=wms&version=1.3.0&request=GetCapabilities

What is my mistake?

2
  • Did you configure the firewall on the AWS VM?
    – Vince
    Aug 3, 2021 at 19:17
  • Yes, I allow inbound traffic 8080 port. I got timeout and sometimes http proxy error and refuse connection
    – endy
    Aug 3, 2021 at 19:28

1 Answer 1

5

Remote Access Configuration

  1. Open ports 8080 for remote GeoServer access on Windows Server: Windows Administrative Tools > Windows Firewall with Advanced Security > Inbound Rules > New Rule > Port TCP > 8080 > Allow > Domain/Private/Public > “8080 GeoServer”

  2. Edit the line of C:\Program Files (x86)\GeoServer 2.xx.0\etc\jetty-http.xml to allow access by all IP addresses (or whatever range that you want):

Note that before remote access through port 8080 is possible, this port must be configured in the EC2 Security Group settings, e.g.,

Custom TCP Rule TCP 8080 0.0.0.0/0 Port for GeoServer

5
  • Any help how to write this parameters in jetty-http.xml "to allow access by all IP addresses" Try to add this: <Call name="addConnector"> <Arg> <New class="org.mortbay.jetty.nio.SelectChannelConnector"> <Set name="port"><SystemProperty name="jetty.port" default="8080"/></Set> <Set name="maxIdleTime">30000</Set> <Set name="Acceptors">2</Set> <Set name="confidentialPort">8443</Set> </New> </Arg> </Call> But not work.
    – endy
    Aug 4, 2021 at 12:21
  • 1
    Here is a document that I prepared for GeoServer 2.14 installation, iIt gives more detail on the configuration: tinyurl.com/ydrnvqse Aug 4, 2021 at 18:00
  • It's work, In the EC2 Network Interface preferences. I configured it with my parameters 8080 TCP and 0.0.0.0/0.
    – endy
    Aug 5, 2021 at 13:06
  • Good deal. Could you mark my comment as the answer to your question? Aug 6, 2021 at 4:48
  • I done it 19 hours ago.
    – endy
    Aug 6, 2021 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.