2

I have a mask that I created. I used calculate geometry in the attribute table to calculate the acres of the polygon (1,214,784 acres). I then used the intersect tool with the mask and another layer to cut the other layer to this exact size. When I calculate the area of this layer and look at the total acreage using statistics, it is 1,214,807 acres. (23 acres larger)

I tried it with the clip tool and got the same result. I thought maybe there was something overlapping so I used the dissolve tool on it and it was still 1,214,807 acres. How could it be larger? I thought maybe it was the coordinate system, but they both appear to be the same.

coordinate systems of each layer

I've tried projecting both layers. I even tried calculating the geometry using both the coordinate system of the data source and the coordinate system of the data frame.

Why it is not calculating the geometry correctly? Or rather, what am I doing wrong?

3
  • 3
    Some things to consider: 23 acres is 0.001893% of 1,214,784 acres. Just because the projection metadata is the same doesn't mean it's accurate (folks clobber existing projections all the time). The tolerances used in Intersect impact the locations of the resulting vertices, only a few of which need to be changed to produce such a small difference.
    – Vince
    Aug 13 at 17:39
  • As @Vince said it sounds like tolerance issue. Have a look at gis.stackexchange.com/questions/48526/…
    – fatih_dur
    Aug 14 at 1:40
  • Please add the exact command used to Intersect the layers (Geoprocessing -> Results -> {session-date} -> {command}... Save As Python Snippet). You might need to report the default tolerances of all three layers. If you don't have access to the Results history, try again using an explicit tolerance and specify that the clip mask has 1 priority.
    – Vince
    Aug 14 at 13:49
0

It turns out I had overlapping areas and areas not connecting in one of the layers. I must have had something selected when I originally ran the intersect on the one layer to check for overlaps because it didn't find anything. I ran erase on the two today and found several places where the vertices weren't lining up in the one layer. I reran intersect and found the same issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.