7

I've been trying to set up a few timed WMS layers in GeoServer. They're simple enough, of the form

ID(PRIMARY KEY) REGION DATE VALUE

so for every region and date you have some value, e.g. the precipitation in that day.

When I set up the layer without time dimensions, I get a working layer where I can see all my regions (although each of them is present multiple times, once for every corresponding date).

Then, I enable the time dimension, with attribute = DATE and presentation = LIST. When I call GetCapabilities, it really contains something like

<Dimension name="time" default="current" units="ISO8601">
  2003-12-31T00:00:00.000Z,2004-12-31T00:00:00.000Z,2005-12-31T00:00:00.000Z
</Dimension>

However, when I request GetMap, results vary.

  • with MS SQLServer backend, I get blank image if the type of DATE column is date, but I get the correct map image if it is datetime
  • with PostGis backend, I always get blank image, whether I use date or timestamp

( one day granularity is enough for my list, so to represent 2003-12-31 I'm ok with using any timestamp within that day )

Note that GeoServer considers all of these datatypes compatible with the time dimension and allows the user to set them as the time attribute.

Has anyone encountered such problems? Am I misunderstanding something about the WMS-T?

EDIT: I've recently found out that timestamptz is the type that works with PostGis. Still, why...?

closed as off-topic by Ian Turton Dec 22 '15 at 16:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Ian Turton
If this question can be reworded to fit the rules in the help center, please edit the question.