-1

When installing the GeoNode 3.2 requirement.txt in the virtualenv I get an error. See error below:

ERROR 1

  Building wheel for pylibmc (setup.py) ... error
  ERROR: Command errored out with exit status 1:
   command: 'C:\Users\lenis\Documents\geonode_env\Scripts\python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\lenis\\AppData\\Local\\Temp\\pip-install-9un_vl6h\\pylibmc_b72a11246894401da7f212c10d770cd4\\setup.py'"'"'; __file__='"'"'C:\\Users\\lenis\\AppData\\Local\\Temp\\pip-install-9un_vl6h\\pylibmc_b72a11246894401da7f212c10d770cd4\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d 'C:\Users\lenis\AppData\Local\Temp\pip-wheel-avjg7tof'
       cwd: C:\Users\lenis\AppData\Local\Temp\pip-install-9un_vl6h\pylibmc_b72a11246894401da7f212c10d770cd4\
  Complete output (20 lines):
  C:\Users\lenis\AppData\Local\Temp\pip-install-9un_vl6h\pylibmc_b72a11246894401da7f212c10d770cd4\setup.py:98: DeprecationWarning: 'U' mode is deprecated
    with open("README.rst", "U", encoding="utf-8") as r:
  C:\Users\lenis\AppData\Local\Temp\pip-install-9un_vl6h\pylibmc_b72a11246894401da7f212c10d770cd4\setup.py:100: DeprecationWarning: 'U' mode is deprecated
    with open("src/pylibmc-version.h", "U", encoding="utf-8") as r:
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build\lib.win-amd64-3.7
  creating build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\autoconf.py -> build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\client.py -> build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\consts.py -> build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\pools.py -> build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\test.py -> build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\__init__.py -> build\lib.win-amd64-3.7\pylibmc
  copying src\pylibmc\__main__.py -> build\lib.win-amd64-3.7\pylibmc
  running build_ext
  building '_pylibmc' extension
  error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
  ----------------------------------------
  ERROR: Failed building wheel for pylibmc

ERROR 2

Running setup.py install for pylibmc ... error
    ERROR: Command errored out with exit status 1:
     command: 'C:\Users\lenis\Documents\geonode_env\Scripts\python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\lenis\\AppData\\Local\\Temp\\pip-install-9un_vl6h\\pylibmc_b72a11246894401da7f212c10d770cd4\\setup.py'"'"'; __file__='"'"'C:\\Users\\lenis\\AppData\\Local\\Temp\\pip-install-9un_vl6h\\pylibmc_b72a11246894401da7f212c10d770cd4\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\lenis\AppData\Local\Temp\pip-record-59thum0c\install-record.txt' --single-version-externally-managed --compile --install-headers 'C:\Users\lenis\Documents\geonode_env\include\site\python3.7\pylibmc'
         cwd: C:\Users\lenis\AppData\Local\Temp\pip-install-9un_vl6h\pylibmc_b72a11246894401da7f212c10d770cd4\
    Complete output (20 lines):
    C:\Users\lenis\AppData\Local\Temp\pip-install-9un_vl6h\pylibmc_b72a11246894401da7f212c10d770cd4\setup.py:98: DeprecationWarning: 'U' mode is deprecated
      with open("README.rst", "U", encoding="utf-8") as r:
    C:\Users\lenis\AppData\Local\Temp\pip-install-9un_vl6h\pylibmc_b72a11246894401da7f212c10d770cd4\setup.py:100: DeprecationWarning: 'U' mode is deprecated
      with open("src/pylibmc-version.h", "U", encoding="utf-8") as r:
    running install
    running build
    running build_py
    creating build
    creating build\lib.win-amd64-3.7
    creating build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\autoconf.py -> build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\client.py -> build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\consts.py -> build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\pools.py -> build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\test.py -> build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\__init__.py -> build\lib.win-amd64-3.7\pylibmc
    copying src\pylibmc\__main__.py -> build\lib.win-amd64-3.7\pylibmc
    running build_ext
    building '_pylibmc' extension
    error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
    ----------------------------------------
ERROR: Command errored out with exit status 1: 'C:\Users\lenis\Documents\geonode_env\Scripts\python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\lenis\\AppData\\Local\\Temp\\pip-install-9un_vl6h\\pylibmc_b72a11246894401da7f212c10d770cd4\\setup.py'"'"'; __file__='"'"'C:\\Users\\lenis\\AppData\\Local\\Temp\\pip-install-9un_vl6h\\pylibmc_b72a11246894401da7f212c10d770cd4\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\lenis\AppData\Local\Temp\pip-record-59thum0c\install-record.txt' --single-version-externally-managed --compile --install-headers 'C:\Users\lenis\Documents\geonode_env\include\site\python3.7\pylibmc' Check the logs for full command output.
0

Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/

1
  • I did exactly this, and now running into another error, error: command 'C:\\Program Files (x86)\\Microsoft Visual Studio\\2019\\BuildTools\\VC\\Tools\\MSVC\\14.29.30133\\bin\\HostX86\\x64\\cl.exe' failed with exit status 2 Aug 21 '21 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.